Multiverse Gaming - Slow Loading Times – Incident details

All systems operational

Slow Loading Times

Resolved
Degraded performance
Started over 1 year agoLasted about 1 month

Affected

Website

Degraded performance from 7:17 PM to 9:57 AM

Forums [Cosmos]

Degraded performance from 7:17 PM to 9:57 AM

Updates
  • Resolved
    Resolved

    Once again this issue seems to have gone away

  • Identified
    Identified

    The issue has returned, we believe we know what is causing it and will be working on a fix

  • Resolved
    Resolved

    Slow loading times have been resolved.

  • Monitoring
    Monitoring

    It seems the loading times have improved, we will continue to monitor.

  • Investigating
    Investigating

    We are currently looking into the slower loading times being experienced on the forums