Multiverse Gaming - Website Error – Incident details

All systems operational

Website Error

Resolved
Major outage
Started 5 days agoLasted about 4 hours

Affected

Website

Major outage from 4:33 PM to 8:23 PM

Landing Page

Major outage from 4:33 PM to 8:23 PM

Forums

Major outage from 4:33 PM to 8:23 PM

Store

Major outage from 4:33 PM to 8:23 PM

Updates
  • Resolved
    Resolved

    After monitoring the website this issue appears to be resolved

    -Dandy

  • Monitoring
    Monitoring

    The website has come back online, we will continue monitoring for the next hour or so

    -Dandy

  • Investigating
    Investigating

    We are aware of an issue affecting all areas of the website currently. We are looking into the cause of this issue