Multiverse Gaming - Forums Down – Incident details

All systems operational

Forums Down

Resolved
Partial outage
Started over 1 year agoLasted 1 minute

Affected

Website

Partial outage from 3:21 PM to 3:22 PM

Forums [Cosmos]

Partial outage from 3:21 PM to 3:22 PM

Updates
  • Resolved
    Resolved

    The forums should be back online again (was a very small outage)

  • Investigating
    Investigating

    We are currently investigating potential downtime with the forums.