Scheduled for February 12, 2024 at 10:30 PM – 10:36 PM
Affects
Palworld
Under maintenance from 10:30 PM to 10:36 PM
Palworld
Under maintenance from 10:30 PM to 10:36 PM
Completed
February 12, 2024 at 10:36 PMCompleted
February 12, 2024 at 10:36 PMThe setting adjustments have been finished.
We are also aware of some rubber banding connection issues, we are looking into these however it is likely outwith our control in the games current state.
In progress
February 12, 2024 at 10:30 PMIn progress
February 12, 2024 at 10:30 PMMaintenance is now in progress
Planned
February 12, 2024 at 10:30 PMPlanned
February 12, 2024 at 10:30 PMThe palworld server will be going briefly offline at 22:30 to adjust some settings to hopefully improve players experience on the server.