Scheduled for July 27, 2024 at 8:10 PM – 11:10 PM
Affects
Gmod
Under maintenance from 8:10 PM to 11:10 PM
Imperial RP
Under maintenance from 8:10 PM to 11:10 PM
Completed
July 27, 2024 at 11:10 PMCompleted
July 27, 2024 at 11:10 PMMaintenance has completed successfully
In progress
July 27, 2024 at 8:10 PMIn progress
July 27, 2024 at 8:10 PMMaintenance is now in progress
Planned
July 27, 2024 at 8:10 PMPlanned
July 27, 2024 at 8:10 PMThe server will be down for the release of the Imperial Weapon Revamp.
This update will add further unique weaponry/attachments to the regiments of the server ranging from explosive AOE bullets, different modes of weapons and allows the player to customize their gun to their playstyle.